problem with IDE 2.8.6f

Topic Specific Tutorials and Tips.

Moderator: Rathinagiri

Post Reply
User avatar
mol
Posts: 2853
Joined: Thu Sep 11, 2008 5:31 am
Location: Myszków, Poland
Has thanked: 123 times
Been thanked: 65 times
Contact:

problem with IDE 2.8.6f

Post by mol » Fri May 29, 2009 7:33 am

I've reached strange problem with IDE 2.8.6.f
I have installed hmg 2.9.1 in c:\hmg - I've checked time and date of files - all libs has 2009.05.10
But, while compiling project with IDE, an error occurs:

Image

and IDE is out.
But, compiled EXE file is built and works good!
And, internal signature of HMG in .exe file points on HMG 2.9.1
(I've deleted all previous HMG from disk, so it's not possible to reach 2.8.9 version)


What's going on?

User avatar
mol
Posts: 2853
Joined: Thu Sep 11, 2008 5:31 am
Location: Myszków, Poland
Has thanked: 123 times
Been thanked: 65 times
Contact:

Post by mol » Fri May 29, 2009 7:56 am

After few compilations, IDE generated .exe file and still lives!!!
Very strange :lol:

User avatar
Roberto Lopez
HMG Founder
Posts: 3900
Joined: Wed Jul 30, 2008 6:43 pm
Has thanked: 13 times
Been thanked: 136 times

Post by Roberto Lopez » Fri May 29, 2009 11:06 am

mol wrote:I've reached strange problem with IDE 2.8.6.f
I have installed hmg 2.9.1 in c:\hmg - I've checked time and date of files - all libs has 2009.05.10
But, while compiling project with IDE, an error occurs:

Image

and IDE is out.
But, compiled EXE file is built and works good!
And, internal signature of HMG in .exe file points on HMG 2.9.1
(I've deleted all previous HMG from disk, so it's not possible to reach 2.8.9 version)


What's going on?

The version of IDE that you are using are compile with 2.8.9.
As the fatal error is in IDE, the HMG version shown is 2.8.9.

I could be more helpful on this if you give some clue about how to reproduce the problem.

TIA.

Regards,

Roberto.
Regards/Saludos,

Roberto


(Veritas Filia Temporis)

User avatar
Roberto Lopez
HMG Founder
Posts: 3900
Joined: Wed Jul 30, 2008 6:43 pm
Has thanked: 13 times
Been thanked: 136 times

Post by Roberto Lopez » Fri May 29, 2009 11:10 am

mol wrote:I've reached strange problem with IDE 2.8.6.f
And...

Had you edited the form code with an external text editor?

Regards,

Roberto.
Regards/Saludos,

Roberto


(Veritas Filia Temporis)

User avatar
mol
Posts: 2853
Joined: Thu Sep 11, 2008 5:31 am
Location: Myszków, Poland
Has thanked: 123 times
Been thanked: 65 times
Contact:

Post by mol » Fri May 29, 2009 1:07 pm

When the first time of error occus, I'm sure that I didn't use any external editor to edit form code - I've copied my project from one computer to second via pendrive.

Second occurance of error - I've use editor to edit main window to duplicate two lines in Main Menu of form - error occured.

Now, I've saved main form from IDE and everythink is OK.

I think, errors was linked with editing forms...

Best regards, Marek

User avatar
Roberto Lopez
HMG Founder
Posts: 3900
Joined: Wed Jul 30, 2008 6:43 pm
Has thanked: 13 times
Been thanked: 136 times

Post by Roberto Lopez » Fri May 29, 2009 1:21 pm

mol wrote:When the first time of error occus, I'm sure that I didn't use any external editor to edit form code - I've copied my project from one computer to second via pendrive.

Second occurance of error - I've use editor to edit main window to duplicate two lines in Main Menu of form - error occured.

Now, I've saved main form from IDE and everythink is OK.

I think, errors was linked with editing forms...

Best regards, Marek
Ok.

I've not documented clearly the fact that reading 'by hand-edited' forms could produce unexpected results and is not guaranteed to work.

I'll remedy in the next release.

Regards,

Roberto.
Regards/Saludos,

Roberto


(Veritas Filia Temporis)

User avatar
mol
Posts: 2853
Joined: Thu Sep 11, 2008 5:31 am
Location: Myszków, Poland
Has thanked: 123 times
Been thanked: 65 times
Contact:

Post by mol » Sun May 31, 2009 12:49 pm

Error occurs after successful compilation - so everything inf form is OK, I think.
Maybe my editor (I use notepad++) puts some extra characters?

I've tried edit form by notepad++ and incremental compiling - it's OK.
But resetting incremental compiling and full building crashes IDE.

Post Reply