Netio as windows service problem

General Help regarding HMG, Compilation, Linking, Samples

Moderator: Rathinagiri

Post Reply
User avatar
karweru
Posts: 178
Joined: Fri Aug 01, 2008 1:51 pm
DBs Used: DBF,mysql,mariadb,postgresql,sqlite,odbc
Been thanked: 7 times
Contact:

Netio as windows service problem

Post by karweru » Sun Mar 03, 2019 5:59 pm

Dear all,

I'm trying to figure out why netio server, running as a windows service, is unable to read config information from a windows registry value written in "HKEY_CURRENT_USER\SOFTWARE\SYSBORA\NETIO". I've also tried to read from a text file with no success. When i run the server, not as a windows service, everything is fine.

The config info is simply the password and port to launch the netio server such that users can configure these for themselves.

I would really appreciate some help, please.
Kind regards,
Gilbert.

trmpluym
Posts: 242
Joined: Tue Jul 15, 2014 6:52 pm
Location: The Netherlands
Has thanked: 6 times
Been thanked: 21 times

Post by trmpluym » Sun Mar 03, 2019 6:04 pm

At the properties of the service, what account are you using ? Try to use an 'Administrator' account.

User avatar
karweru
Posts: 178
Joined: Fri Aug 01, 2008 1:51 pm
DBs Used: DBF,mysql,mariadb,postgresql,sqlite,odbc
Been thanked: 7 times
Contact:

Post by karweru » Sun Mar 03, 2019 6:24 pm

Perfect, thank you very much. It now works.
Kind regards,
Gilbert.

User avatar
karweru
Posts: 178
Joined: Fri Aug 01, 2008 1:51 pm
DBs Used: DBF,mysql,mariadb,postgresql,sqlite,odbc
Been thanked: 7 times
Contact:

Post by karweru » Thu Mar 21, 2019 4:41 pm

Putting the config file in GetSystemFolder() also works.
Kind regards,
Gilbert.

Post Reply