Compatibility issue with Win7 and WinXP

General Help regarding HMG, Compilation, Linking, Samples

Moderator: Rathinagiri

RPC
Posts: 245
Joined: Fri Feb 10, 2017 4:12 am
DBs Used: DBF
Has thanked: 138 times
Been thanked: 14 times

Compatibility issue with Win7 and WinXP

Post by RPC »

Hi
I have complied a program in Win10 64 bit to download files from internet.
The program downloads files on my laptop.
However when it is run on win7 or winXP nothing is downloaded.
Can anyone please help me solve this problem.
I have enclosed the program

Thanks
Attachments
DCDQuotes.zip
(22.22 KiB) Downloaded 35 times

User avatar
AUGE_OHR
Posts: 1305
Joined: Sun Aug 25, 2019 3:12 pm
DBs Used: DBF, PostgreSQL, MySQL, SQLite
Location: Hamburg, Germany
Has thanked: 244 times
Been thanked: 370 times

Post by AUGE_OHR »

hi,

does "MSXML2.ServerXMLHTTP" exist on Windows XP :?:

as i know older Version use "IE" as Engine.
have fun
Jimmy

RPC
Posts: 245
Joined: Fri Feb 10, 2017 4:12 am
DBs Used: DBF
Has thanked: 138 times
Been thanked: 14 times

Post by RPC »

AUGE_OHR wrote:
Fri Apr 02, 2021 8:23 pm
hi,

does "MSXML2.ServerXMLHTTP" exist on Windows XP :?:

as i know older Version use "IE" as Engine.
Thanks Jimmy for quick answer.
I really don't know about if "MSXML2.ServerXMLHTTP" exist in XP.
Actually I don't even know what this is.
I was given code to download by Edward(edk)(Thank you Edward) and I have used it in my this module.
Is "MSXML2.ServerXMLHTTP" also not available in win7 because I was informed the program is also not working in win 7 64 bit.
Can you please suggest some solution.
Many thanks.

edk
Posts: 672
Joined: Thu Oct 16, 2014 11:35 am
Location: Poland
Has thanked: 155 times
Been thanked: 610 times

Post by edk »

Hi. I think TLS is the problem. From what I can see, the site you want to download from is currently using TLS 1.3, and from what I remember, Windows XP and Windows 7 don't support this protocol.
nseindia.png
nseindia.png (127.67 KiB) Viewed 396 times
Any inquiries sent without TLSv1.3 support may be rejected by the server.

RPC
Posts: 245
Joined: Fri Feb 10, 2017 4:12 am
DBs Used: DBF
Has thanked: 138 times
Been thanked: 14 times

Post by RPC »

edk wrote:
Mon Apr 05, 2021 11:23 am
Hi. I think TLS is the problem. From what I can see, the site you want to download from is currently using TLS 1.3, and from what I remember, Windows XP and Windows 7 don't support this protocol.
nseindia.png
Any inquiries sent without TLSv1.3 support may be rejected by the server.
Thank you very much for the response.
Can you please suggest any way out.
There is another error posted on the forum where I posted my program to download quotes for which you had provided me links and relevant code. I have enclosed SS
Please have a look .
Thanks
Rajeev
Attachments
dquote.png
dquote.png (246.97 KiB) Viewed 365 times

edk
Posts: 672
Joined: Thu Oct 16, 2014 11:35 am
Location: Poland
Has thanked: 155 times
Been thanked: 610 times

Post by edk »

Rajeev, the same problem, does not support last TLS. I am currently not using an old unsupported operating system. Maybe try to check how to enable TLS 1.2 on Win 7, maybe that fixes the problem.

RPC
Posts: 245
Joined: Fri Feb 10, 2017 4:12 am
DBs Used: DBF
Has thanked: 138 times
Been thanked: 14 times

Post by RPC »

Hi Edward,

Thanks for your suggestion.

I have found a link here which explains how to enable TLS 1.2 on win 7.

I really apologize for bothering you so much.

Many thanks
Rajeev

edk
Posts: 672
Joined: Thu Oct 16, 2014 11:35 am
Location: Poland
Has thanked: 155 times
Been thanked: 610 times

Post by edk »

I found something like this (also for XP): https://www.emailarchitect.net/easendma ... ls12_a.htm
It seems that after enabling TLS 1.2 for EWS (WinHttp) it should work. I have not tested :!:

RPC
Posts: 245
Joined: Fri Feb 10, 2017 4:12 am
DBs Used: DBF
Has thanked: 138 times
Been thanked: 14 times

Post by RPC »

edk wrote:
Tue Apr 06, 2021 8:42 am
I found something like this (also for XP): https://www.emailarchitect.net/easendma ... ls12_a.htm
It seems that after enabling TLS 1.2 for EWS (WinHttp) it should work. I have not tested :!:
Thanks again Edward.
I will try this on my winXP and hope it works.

RPC
Posts: 245
Joined: Fri Feb 10, 2017 4:12 am
DBs Used: DBF
Has thanked: 138 times
Been thanked: 14 times

Post by RPC »

RPC wrote:
Tue Apr 06, 2021 10:22 am
edk wrote:
Tue Apr 06, 2021 8:42 am
I found something like this (also for XP): https://www.emailarchitect.net/easendma ... ls12_a.htm
It seems that after enabling TLS 1.2 for EWS (WinHttp) it should work. I have not tested :!:
Thanks again Edward.
I will try this on my winXP and hope it works.
I have tried installing patches for enabling TLSv1.2 on my winXP .
It seems there are compatibility issues between my winXP and the patch :( .
I get a message "The version of windows you have installed does not match the update you are trying to install"

Still happy my program is at least working on win 10

Thank you Edward(edk) for all you efforts and time

Rajeev

Post Reply