HMG 3.3.0 trouble with 64 bit compilation

Moderator: Rathinagiri

Post Reply
User avatar
meneale
Posts: 51
Joined: Sat Jan 12, 2013 2:05 am
Location: Campinas -SP, Brasil

HMG 3.3.0 trouble with 64 bit compilation

Post by meneale » Tue May 27, 2014 9:54 pm

I'm having the following troubles with HMG 3.3.0 compilation in 64 bit
  • during compilation, the Build64.bat or the IDE returns: windres preprocessing failed
  • this means that the windres not found hmg64.rc
  • even duplicating the hmg.rc to hmg64.rc, HMG build it, but in 32 bit according Windows Task Manager :oops:
    Image
What should I do? thanks.
AMD Phenom II X6 1090T 3.2GHz (OverClock 3.9GHz) | Windows 8.1 Pro 64-bit
4GB DDR3 | GTX 550 Ti 1GB | MSI 880GMA-E35

User avatar
srvet_claudio
Posts: 1958
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 32 times
Been thanked: 125 times
Contact:

Post by srvet_claudio » Tue May 27, 2014 11:01 pm

The HMG.3.3.0 version is not complete (missing 64-bits libraries).
Missing a patch that Rathi will prepare with the following folders needed to build 64-bit app:
- Harbour-64
- MinGW-64
- Lib-64
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

User avatar
srvet_claudio
Posts: 1958
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 32 times
Been thanked: 125 times
Contact:

Post by srvet_claudio » Tue May 27, 2014 11:12 pm

srvet_claudio wrote:The HMG.3.3.0 version is not complete (missing 64-bits libraries).
Missing a patch that Rathi will prepare with the following folders needed to build 64-bit app:
- Harbour-64
- MinGW-64
- Lib-64
I forgot, to create 64-bit applications should be compiled with build64.bat or with the IDE you select option "build" in main menu.
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

User avatar
meneale
Posts: 51
Joined: Sat Jan 12, 2013 2:05 am
Location: Campinas -SP, Brasil

Post by meneale » Tue May 27, 2014 11:51 pm

Thank for the info
I compiled with build64.bat, or in IDE chosing Build->64-bits. Also compiled Libs with _BuildAllLib64.bat
AMD Phenom II X6 1090T 3.2GHz (OverClock 3.9GHz) | Windows 8.1 Pro 64-bit
4GB DDR3 | GTX 550 Ti 1GB | MSI 880GMA-E35

Post Reply