HMG 3.4.3

HMG Unicode versions 3.1.x related

Moderator: Rathinagiri

User avatar
srvet_claudio
Posts: 2024
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 34 times
Been thanked: 143 times
Contact:

Re: HMG 3.4.3

Post by srvet_claudio » Mon Mar 27, 2017 4:03 pm

Rathinagiri wrote:
Mon Mar 27, 2017 2:49 pm
Until now the new version of IDE didn't give problems. I will confirm after using tomorrow also.
Thanks for the info.

In the earlier version of the IDE I had for error HMG compiled with incremental enabled and with debuginfo in on.
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

User avatar
mol
Posts: 3027
Joined: Thu Sep 11, 2008 5:31 am
Location: Myszków, Poland
Has thanked: 167 times
Been thanked: 92 times
Contact:

Post by mol » Mon Mar 27, 2017 4:22 pm

I'm testing this version of IDE, too.
I haven' t problems in previous versio, current working ok too.

User avatar
srvet_claudio
Posts: 2024
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 34 times
Been thanked: 143 times
Contact:

Post by srvet_claudio » Mon Mar 27, 2017 5:16 pm

mol wrote:
Mon Mar 27, 2017 4:22 pm
I'm testing this version of IDE, too.
I haven' t problems in previous versio, current working ok too.
Thanks
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

User avatar
Pablo César
Posts: 4059
Joined: Wed Sep 08, 2010 1:18 pm
Location: Curitiba - Brasil
Has thanked: 100 times
Been thanked: 179 times

Post by Pablo César » Mon Mar 27, 2017 6:45 pm

Rathinagiri wrote:
Mon Mar 27, 2017 2:49 pm
Until now the new version of IDE didn't give problems. I will confirm after using tomorrow also.
+1
HMGing a better world
"Matter tells space how to curve, space tells matter how to move."
Albert Einstein

User avatar
srvet_claudio
Posts: 2024
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 34 times
Been thanked: 143 times
Contact:

Post by srvet_claudio » Mon Mar 27, 2017 7:32 pm

Pablo César wrote:
Mon Mar 27, 2017 6:45 pm
Rathinagiri wrote:
Mon Mar 27, 2017 2:49 pm
Until now the new version of IDE didn't give problems. I will confirm after using tomorrow also.
+1
Thanks
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

Karl
Posts: 39
Joined: Tue Mar 14, 2017 12:24 pm
DBs Used: DBF
Has thanked: 10 times
Been thanked: 2 times

Post by Karl » Tue Mar 28, 2017 7:56 am

Hi Claudio,

the recent version of IDE froze every time after 15-20 cycles of compiling. With your new version it doesn´t happen and I´m very happy.

Thanks a lot.

Have a good day
Karl

WIN 7 Pro 64-bit, HMG 3.4.3 IDE 1.2a
WIN 10 64-bit, WIN 7 32-bit, HMG 3.4.4, 32-bit

User avatar
srvet_claudio
Posts: 2024
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 34 times
Been thanked: 143 times
Contact:

Post by srvet_claudio » Tue Mar 28, 2017 11:45 am

Karl wrote:
Tue Mar 28, 2017 7:56 am
Hi Claudio,

the recent version of IDE froze every time after 15-20 cycles of compiling. With your new version it doesn´t happen and I´m very happy.

Thanks a lot.

Have a good day
Karl

WIN 7 Pro 64-bit, HMG 3.4.3 IDE 1.2a
Thanks
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

User avatar
salamandra
Posts: 132
Joined: Thu Jul 31, 2008 8:33 pm
Location: Brazil
Has thanked: 1 time
Been thanked: 1 time

Post by salamandra » Tue Mar 28, 2017 11:58 am

srvet_claudio wrote:
Wed Mar 22, 2017 2:19 pm
salamandra wrote:
Wed Mar 22, 2017 2:08 pm
Hi Dr Claudio,
Thank you very much for your help !!

Is a very strange error, libwinpthread-1.dll is need because the pthread lib is not linked in static mode, the hbmk2 directive -ldflag="-pthread -static -lpthread" has not efect. What is your Windows versión and your compile is in ANSI o Unicode?

Please try change in your build.bat
-ldflag="-pthread -static -lpthread"

For:
-ldflag="-pthread -static-libgcc -static-libstdc++ -static -lpthread"
I did what you suggested and the problem with libwinpthread-1.dll was solved. ;) ;)

My working environment: Windows 7, 32 bits, libraries compiled in ANSI mode, HMG installed in the local disk (c:\) and my working (sources) and running directory for the compiled program it is located in a Network drive.

I have downloaded this install package HMG3.4.3, applied Pack 1,built libraries, applied pack 2 and built libraries again.

Another strange fact: yesterday I did some tests with HMG versions 3.4.0., 3.4.1 and 3.4.2 and the problem with HMG_GridInPlaceEdit() also occurs exactly the same way.

TIA,
[]´s Salamandra
Please post a small demo that show the bug in HMG_GridInPlaceEdit()
Ok Dr Claudio, I'll try to do.



[]´s Salamandra
There is one time in which is crucial awakening. That time is now. ( Buddha )

User avatar
Pablo César
Posts: 4059
Joined: Wed Sep 08, 2010 1:18 pm
Location: Curitiba - Brasil
Has thanked: 100 times
Been thanked: 179 times

Post by Pablo César » Wed Mar 29, 2017 3:38 am

Hi Claudio,

I am sorry to tell you IDE crashed again with this last version 1.2a :|

Crashed at begining of this night.

I've used a lot today, was not so frequently (twince in probably 60 compilations). I do not the number exactly.

I will prepare a counter and when I know it's crashed, I can turn on to zero again for finally to report to you.
HMGing a better world
"Matter tells space how to curve, space tells matter how to move."
Albert Einstein

User avatar
Pablo César
Posts: 4059
Joined: Wed Sep 08, 2010 1:18 pm
Location: Curitiba - Brasil
Has thanked: 100 times
Been thanked: 179 times

Post by Pablo César » Wed Mar 29, 2017 4:27 am

Hi All,

I just prepared CountCompile.exe to count the number of compilations for who wish to help us to find the number of compilations with IDE.

For more details how to install it and use, please read this: viewtopic.php?p=50582#p50582
 
Last edited by Pablo César on Sun Apr 02, 2017 2:53 pm, edited 1 time in total.
HMGing a better world
"Matter tells space how to curve, space tells matter how to move."
Albert Einstein

Post Reply