HMG.3.4.2

HMG Unicode versions 3.1.x related

Moderator: Rathinagiri

User avatar
srvet_claudio
Posts: 1948
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 30 times
Been thanked: 118 times
Contact:

Re: HMG.3.4.2

Post by srvet_claudio » Fri Apr 29, 2016 5:38 pm

chrisjx2002 wrote:I think it works. I have probably found where there is a problem. Thanks Claudio for your help!
The original demo of the link that you post have a small bug.
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

chrisjx2002
Posts: 153
Joined: Wed Jan 06, 2010 5:39 pm
Been thanked: 2 times

Post by chrisjx2002 » Fri Apr 29, 2016 7:20 pm

You are right!

chrisjx2002
Posts: 153
Joined: Wed Jan 06, 2010 5:39 pm
Been thanked: 2 times

Post by chrisjx2002 » Fri Apr 29, 2016 7:32 pm

Try to change Form_1.Button_1.Picture := "" by Setproperty("Form_1","Button_1","caption","") in your program. Then it does not work : the image is not suppress.

User avatar
srvet_claudio
Posts: 1948
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 30 times
Been thanked: 118 times
Contact:

Post by srvet_claudio » Fri Apr 29, 2016 9:43 pm

chrisjx2002 wrote:Try to change Form_1.Button_1.Picture := "" by Setproperty("Form_1","Button_1","caption","") in your program. Then it does not work : the image is not suppress.
The property is PICTURE not is CAPTION:

Code: Select all

	SetProperty( "Form_1", "Button_1", "Picture", "" )
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

User avatar
esgici
Posts: 4337
Joined: Wed Jul 30, 2008 9:17 pm
DBs Used: DBF
Location: iskenderun / Turkiye
Has thanked: 221 times
Been thanked: 77 times
Contact:

Post by esgici » Fri Apr 29, 2016 9:44 pm

Wonderful !

Thanks Claudio :D
Viva INTERNATIONAL HMG :D

User avatar
srvet_claudio
Posts: 1948
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 30 times
Been thanked: 118 times
Contact:

Post by srvet_claudio » Sat Apr 30, 2016 12:19 am

srvet_claudio wrote:
nikko1960 wrote:Hi to all
configuration : win 10 home 64 bit, hmg 3.4.2 ide unicode patch 3, timer control.
i do not know if this is an issue but when you input the value property from Ide the maximum value is 10000 ( i think is equal to ten seconds )
but if you change it in the fmg file you can input more then 10000, it works as expected.
So i suggest to increase this value in HMG-Ide property value.

regards

Domenico
I will check.
Done !
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

chrisjx2002
Posts: 153
Joined: Wed Jan 06, 2010 5:39 pm
Been thanked: 2 times

Post by chrisjx2002 » Sat Apr 30, 2016 10:45 am

You are right... :oops: I was definitively too tired yesterday evening....

User avatar
srvet_claudio
Posts: 1948
Joined: Thu Feb 25, 2010 8:43 pm
Location: Uruguay
Has thanked: 30 times
Been thanked: 118 times
Contact:

Post by srvet_claudio » Sun May 01, 2016 12:12 am

Hi Friends,
Please test the new version of IDE (ver 1.1)
- now the IDE not convert to lowercase the name of the PRG files
- eliminated the maximum limit of 10000 milliseconds in the Timer control imposed for the IDE
- Zero in MAXLENGTH property of the controls RichEdit, TextBox and EditBox is equal a NIL value
- now double click on the Run or Debug buttons not abort the IDE
Attachments
IDE_ver 1.1.rar
(2.97 MiB) Downloaded 168 times
Best regards.
Dr. Claudio Soto
(from Uruguay)
http://srvet.blogspot.com

User avatar
esgici
Posts: 4337
Joined: Wed Jul 30, 2008 9:17 pm
DBs Used: DBF
Location: iskenderun / Turkiye
Has thanked: 221 times
Been thanked: 77 times
Contact:

Post by esgici » Sun May 01, 2016 12:56 am

srvet_claudio wrote:Hi Friends,
Please test the new version of IDE (ver 1.1)
- now the IDE not convert to lowercase the name of the PRG files
- eliminated the maximum limit of 10000 milliseconds in the Timer control imposed for the IDE
- Zero in MAXLENGTH property of the controls RichEdit, TextBox and EditBox is equal a NIL value
- now double click on the Run or Debug buttons not abort the IDE
Thanks Claudio :D
Viva INTERNATIONAL HMG :D

User avatar
quartz565
Posts: 446
Joined: Mon Oct 01, 2012 12:37 pm
Location: Thessaloniki, Greece
Has thanked: 103 times
Been thanked: 11 times
Contact:

Post by quartz565 » Sun May 01, 2016 6:11 pm

Thank you Claudio !
Best Regards,
Nikos.

os: Windows Server 2012 - 64
hw: HP Server E5606, 2.13GHz, 8.00 GB - Intel Xeon CPU

Post Reply