Page 1 of 1

HMGIde 2.8.6f - Problem with PICTURE property in Button

Posted: Sun May 24, 2009 6:51 pm
by salamandra
:) Hi to all,
I've detected a problem using HMGIde 2.8.6f (if really this is a problem...)
Assuming that I've created a Form and inserted two buttons: Button_1 and Button_2.
In Button_1 I've defined PICTURE property as a resource file (image01),
corresponding to existing file ok02.bmp.
In Button_2 I've defined PICTURE property as a file ( ok02.bmp)
After Build, when the app runs, only Button_2 shows a picture.
image.JPG
image.JPG (18.08 KiB) Viewed 3363 times
For better understanding, see attached sample.


Best regards,

Salamandra[

Re: HMGIde 2.8.6f - Problem with PICTURE property in Button

Posted: Sun May 24, 2009 8:04 pm
by esgici
Hi Salamandra

Simply change :

image01 BMP ok02.bmp

line to

image01 BITMAP ok02.bmp

in your resource.

Regards

--

Esgici

Re: HMGIde 2.8.6f - Problem with PICTURE property in Button

Posted: Sun May 24, 2009 8:31 pm
by salamandra
:) Hi esguici,

esgici wrote: Simply change :
image01 BMP ok02.bmp
line to
image01 BITMAP ok02.bmp
in your resource.
Oh my God !!! .... I am really embarrassed.... :oops: :oops: :oops: :oops:
I wrote resource files at least 25000 times...
I don't imagine how I could commit this grotesque error...

Sorry, Sorry and Sorry again.

Thank you very much for your help.


Best Regards,

Salamandra

Re: HMGIde 2.8.6f - Problem with PICTURE property in Button

Posted: Mon May 25, 2009 6:49 pm
by esgici
Hi Salamandra

Please don't worry so much !

Most unnoticeable faults are simplest ones :o

Regards

--

Esgici

Re: HMGIde 2.8.6f - Problem with PICTURE property in Button

Posted: Mon May 25, 2009 6:57 pm
by salamandra
Hi esgici,

esgici wrote:Please don't worry so much ! Most unnoticeable faults are simplest ones

:)


Salamandra